DSA-2020-024: RSA NetWitness Logs and Network Security Update for Multiple Third Party Component Vulnerabilities

Document created by RSA Product Team Employee on Jan 31, 2020Last modified by RSA Product Team Employee on Jan 31, 2020
Version 2Show Document
  • View in full screen mode
Dell EMC Identifier:DSA-2020-024
CVE Identifier:CVE-2018-20856, CVE-2019-10126, CVE-2019-3846, CVE-2019-9506, CVE-2019-14835, CVE-2018-10853, CVE-2018-13053, CVE-2018-13093, CVE-2018-13094, CVE-2018-13095, CVE-2018-14625, CVE-2018-14734, CVE-2018-15594, CVE-2018-16658, CVE-2018-16885, CVE-2018-18281, CVE-2018-7755, CVE-2018-8087, CVE-2018-9363, CVE-2018-9516, CVE-2018-9517, CVE-2019-11599, CVE-2019-11810, CVE-2019-11833, CVE-2019-3459, CVE-2019-3460, CVE-2019-3882, CVE-2019-3900, CVE-2019-5489, CVE-2019-7222, CVE-2019-1125, CVE-2019-9500, CVE-2018-12207, CVE-2019-0154, CVE-2019-11135, CVE-2019-0155, CVE-2018-14646, CVE-2018-14633, CVE-2015-9251, CVE-2019-11358, CVE-2019-6470, CVE-2018-20060, CVE-2019-11236, CVE-2018-18074, CVE-2018-14647, CVE-2019-5010, CVE-2019-9740, CVE-2019-9947, CVE-2019-9948, CVE-2018-14598, CVE-2018-14599, CVE-2018-14600, CVE-2018-15853, CVE-2018-15854, CVE-2018-15855, CVE-2018-15856, CVE-2018-15857, CVE-2018-15859, CVE-2018-15861, CVE-2018-15862, CVE-2018-15863, CVE-2018-15864, CVE-2018-19788, CVE-2018-5741, CVE-2018-15473, CVE-2018-0495, CVE-2018-12404, CVE-2016-10739, CVE-2018-16062, CVE-2018-16402, CVE-2018-16403, CVE-2018-18310, CVE-2018-18520, CVE-2018-18521, CVE-2019-7149, CVE-2019-7150, CVE-2019-7664, CVE-2019-7665, CVE-2018-1122, CVE-2018-5383, CVE-2018-15686, CVE-2018-16866, CVE-2018-16888, CVE-2018-16842, CVE-2018-1000876, CVE-2018-12641, CVE-2018-12697, CVE-2019-3858, CVE-2019-3861, CVE-2018-16881, CVE-2018-7409, CVE-2018-7485, CVE-2018-18384, CVE-2016-3186, CVE-2018-10779, CVE-2018-10963, CVE-2018-12900, CVE-2018-17100, CVE-2018-17101, CVE-2018-18557, CVE-2018-18661, CVE-2018-7456, CVE-2018-8905, CVE-2018-3058, CVE-2018-3063, CVE-2018-3066, CVE-2018-3081, CVE-2018-3282, CVE-2019-2503, CVE-2019-2529, CVE-2019-2614, CVE-2019-2627, CVE-2018-18584, CVE-2018-18585, CVE-2019-0217, CVE-2019-0220, CVE-2018-14348, CVE-2019-14287, CVE-2018-12327, CVE-2019-3880, CVE-2018-0734, CVE-2019-1559, CVE-2019-2945, CVE-2019-2949, CVE-2019-2962, CVE-2019-2964, CVE-2019-2973, CVE-2019-2975, CVE-2019-2977, CVE-2019-2978, CVE-2019-2981, CVE-2019-2983, CVE-2019-2987, CVE-2019-2988, CVE-2019-2989, CVE-2019-2992, CVE-2019-2999, CVE-2018-18311, CVE-2018-14679, CVE-2018-14680, CVE-2018-14681, CVE-2018-14682, CVE-2019-3815, CVE-2018-5742, CVE-2018-1050, CVE-2018-1139, CVE-2018-10858, CVE-2018-10906, CVE-2017-3735, CVE-2018-0732, CVE-2018-0737, CVE-2018-0739, CVE-2018-14665, CVE-2015-9262, CVE-2016-2183, CVE-2018-1000007, CVE-2018-1000120, CVE-2018-1000121, CVE-2018-1000122, CVE-2018-1000301, CVE-2017-18267, CVE-2018-10733, CVE-2018-10767, CVE-2018-10768, CVE-2018-12910, CVE-2018-13988
Severity:High
Severity Rating:CVSS v3 Base Score: See NVD (http://nvd.nist.gov/) for individual scores for each CVE
Affected Products:RSA NetWitness Platform versions prior to 11.4
Summary:

Multiple components within RSA NetWitness Platform require a security update to address various vulnerabilities. 

Details:

The embedded components are updated for the following vulnerabilities:

 

  • Kernel: CVE-2018-20856, CVE-2019-10126, CVE-2019-3846, CVE-2019-9506, CVE-2019-14835, CVE-2018-10853, CVE-2018-13053, CVE-2018-13093, CVE-2018-13094, CVE-2018-13095, CVE-2018-14625, CVE-2018-14734, CVE-2018-15594, CVE-2018-16658, CVE-2018-16885, CVE-2018-18281, CVE-2018-7755, CVE-2018-8087, CVE-2018-9363, CVE-2018-9516, CVE-2018-9517, CVE-2019-11599, CVE-2019-11810, CVE-2019-11833, CVE-2019-3459, CVE-2019-3460, CVE-2019-3882, CVE-2019-3900, CVE-2019-5489, CVE-2019-7222, CVE-2019-1125, CVE-2019-9500, CVE-2018-12207, CVE-2019-0154, CVE-2019-11135, CVE-2019-0155, CVE-2018-14646, CVE-2018-14633

https://access.redhat.com/errata/RHSA-2019:2829

https://access.redhat.com/errata/RHSA-2018:3651

https://access.redhat.com/errata/RHSA-2018:2768

https://access.redhat.com/errata/RHSA-2019:2029

https://access.redhat.com/errata/RHSA-2019:2600

https://access.redhat.com/errata/RHSA-2019:3834

 

https://access.redhat.com/errata/RHSA-2019:3872

 

  • rabbitmq : CVE-2015-9251, CVE-2019-11358

https://bedfordjira.na.rsa.net/browse/ASOC-60260

  • dhcp: CVE-2019-6470

https://access.redhat.com/errata/RHSA-2019:2060

  • Python: CVE-2018-20060, CVE-2019-11236, CVE-2018-18074, CVE-2018-14647, CVE-2019-5010, CVE-2019-9740, CVE-2019-9947, CVE-2019-9948, CVE-2018-14647, CVE-2019-5010, CVE-2019-9740, CVE-2019-9947, CVE-2019-9948, CVE-2016-2183

https://access.redhat.com/errata/RHSA-2018:2123

https://access.redhat.com/errata/RHSA-2019:2030

https://access.redhat.com/errata/RHSA-2019:2035

https://access.redhat.com/errata/RHSA-2019:2272

  • Libx11: CVE-2018-14598, CVE-2018-14599, CVE-2018-14600, CVE-2018-15853, CVE-2018-15854, CVE-2018-15855, CVE-2018-15856, CVE-2018-15857, CVE-2018-15859, CVE-2018-15861, CVE-2018-15862, CVE-2018-15863, CVE-2018-15864

https://access.redhat.com/errata/RHSA-2019:2079

  • polkit: CVE-2018-19788

https://access.redhat.com/errata/RHSA-2019:2046

  • bind: CVE-2018-5741

https://access.redhat.com/errata/RHSA-2019:2057

  • openssh: CVE-2018-15473

https://access.redhat.com/errata/RHSA-2019:2143

  • nspr: CVE-2018-0495, CVE-2018-12404

https://access.redhat.com/errata/RHSA-2019:2237

  • glibc: CVE-2016-10739

https://access.redhat.com/errata/RHSA-2019:2118

  • elfutils: CVE-2018-16062, CVE-2018-16402, CVE-2018-16403, CVE-2018-18310, CVE-2018-18520, CVE-2018-18521, CVE-2019-7149, CVE-2019-7150, CVE-2019-7664, CVE-2019-7665

https://access.redhat.com/errata/RHSA-2019:2197

  • procps: CVE-2018-1122

https://access.redhat.com/errata/RHSA-2019:2189

  • linux-firmware: CVE-2018-5383

https://access.redhat.com/errata/RHSA-2019:2169

  • systemd: CVE-2018-15686, CVE-2018-16866, CVE-2018-16888

https://access.redhat.com/errata/RHSA-2019:2091

  • curl: CVE-2018-16842

https://access.redhat.com/errata/RHSA-2019:2181

  • binutils: CVE-2018-1000876, CVE-2018-12641, CVE-2018-12697

https://access.redhat.com/errata/RHSA-2019:2075

  • libssh2: CVE-2019-3858, CVE-2019-3861

https://access.redhat.com/errata/RHSA-2019:2136\

  • rsyslog: CVE-2018-16881

https://access.redhat.com/errata/RHSA-2019:2110

  • unixODBC: CVE-2018-7409, CVE-2018-7485

https://access.redhat.com/errata/RHSA-2019:2336

  • unzip: CVE-2018-18384

https://access.redhat.com/errata/RHSA-2019:2159

  • libtiff: CVE-2016-3186, CVE-2018-10779, CVE-2018-10963, CVE-2018-12900, CVE-2018-17100, CVE-2018-17101, CVE-2018-18557, CVE-2018-18661, CVE-2018-7456, CVE-2018-8905

https://access.redhat.com/errata/RHSA-2019:2053

  • mariadb: CVE-2018-3058, CVE-2018-3063, CVE-2018-3066, CVE-2018-3081, CVE-2018-3282, CVE-2019-2503, CVE-2019-2529, CVE-2019-2614, CVE-2019-2627

https://access.redhat.com/errata/RHSA-2019:2327

  • libmspack: CVE-2018-18584, CVE-2018-18585

https://access.redhat.com/errata/RHSA-2019:2049

  • httpd: CVE-2019-0217, CVE-2019-0220

https://access.redhat.com/errata/RHSA-2019:2343

  • libcgroup: CVE-2018-14348

https://access.redhat.com/errata/RHSA-2019:2047

  • sudo: CVE-2019-14287

https://access.redhat.com/errata/RHSA-2019:3197

  • ntp: CVE-2018-12327

https://access.redhat.com/errata/RHSA-2019:2077

  • samba: CVE-2019-3880

https://access.redhat.com/errata/RHSA-2019:2099

  • Openssl: CVE-2018-0734, CVE-2019-1559

https://access.redhat.com/errata/RHSA-2019:2304

  • openjdk: CVE-2019-2945, CVE-2019-2949, CVE-2019-2962, CVE-2019-2964, CVE-2019-2973, CVE-2019-2975, CVE-2019-2977, CVE-2019-2978, CVE-2019-2981, CVE-2019-2983, CVE-2019-2987, CVE-2019-2988, CVE-2019-2989, CVE-2019-2992, CVE-2019-2999

https://access.redhat.com/errata/RHSA-2019:3127

  • perl: CVE-2018-18311

https://access.redhat.com/errata/RHSA-2019:0109

  • libmspack: CVE-2018-14679, CVE-2018-14680, CVE-2018-14681, CVE-2018-14682

https://access.redhat.com/errata/RHSA-2018:3327

  • systemd: CVE-2019-3815

https://access.redhat.com/errata/RHSA-2019:0201

  • bind: CVE-2018-5742

https://access.redhat.com/errata/RHSA-2019:0194

  • samba: CVE-2018-1050, CVE-2018-1139, CVE-2018-10858

https://access.redhat.com/errata/RHSA-2018:3056

  • fuse: CVE-2018-10906

https://access.redhat.com/errata/RHSA-2018:3324

  • Openssl: CVE-2017-3735, CVE-2018-0495, CVE-2018-0732, CVE-2018-0737, CVE-2018-0739

https://access.redhat.com/errata/RHSA-2018:3221

  • xorg-x11-server: CVE-2018-14665

https://access.redhat.com/errata/RHSA-2018:3410

https://lists.centos.org/pipermail/centos-cr-announce/2018-November/005745.html

  • xkeyboard-config, xorg-x11-xkb-utils, xkeyboard-config, xorg-x11-font-utils, mesa-libEGL, mesa-libGL, mesa-libgbm, mesa-libglapi, libXfont2, libXfont, libXcursor, libxcb, libX11, libX11-common, libepoxy, libdrm : CVE-2015-9262

https://access.redhat.com/errata/RHSA-2018:3059

  • vsftpd: CVE-2015-4000
  • curl, nss-pem: CVE-2018-1000007, CVE-2018-1000120, CVE-2018-1000121, CVE-2018-1000122, CVE-2018-1000301

https://access.redhat.com/errata/RHSA-2018:3157

  • pango, libcroco, harfbuzz, gobject-introspection, gdk-pixbuf2, freetype, glib2, fontconfig, cairo, atk, gtk-update-icon-cache: CVE-2017-18267, CVE-2018-10733, CVE-2018-10767, CVE-2018-10768, CVE-2018-12910, CVE-2018-13988

https://access.redhat.com/errata/RHSA-2018:3140

 

For more information about any of the Common Vulnerabilities and Exposures (CVEs) mentioned here, consult the National Vulnerability Database (NVD) at https://nvd.nist.gov/home#. To search for a particular CVE, use the database’s search utility at https://nvd.nist.gov/search

Recommendation:

The following RSA NetWitness Platform release contains resolutions to these vulnerabilities:

  • RSA NetWitness Platform version 11.4

 

RSA recommends all customers upgrade at the earliest opportunity.

Severity Rating:For an explanation of Severity Ratings, refer to Dell’s Vulnerability Disclosure Policy. RSA recommends all customers take into account both the base score and any relevant temporal and environmental scores which may impact the potential severity associated with particular security vulnerability.
EOPS Policy:RSA has a defined End of Primary Support policy associated with all major versions. Please refer to the Product Version Life Cycle for additional details.
Legal Information:

Read and use the information in this RSA Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this advisory, contact RSA Customer Support. RSA Security LLC and its affiliates, including without limitation, its ultimate parent company, Dell Technologies, distribute RSA Security Advisories in order to bring to the attention of users of the affected RSA products, important security information.

 

RSA recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. RSA disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement.

 

In no event shall RSA, its affiliates or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if RSA, its affiliates or its suppliers have been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.

Attachments

    Outcomes